cPanel® Blog

We’re Moving to Perl 5.22 in cPanel & WHM Version 56

If you use custom code on your cPanel & WHM servers, please read this message! Without further action on your part, your custom code may break in cPanel & WHM version 56.

In version 56, we will compile the cPanel & WHM binaries against Perl version 5.22. Previously, we compiled binaries against Perl 5.14.4. Because of this, the upgrade to Perl 5.22 may cause problems with any custom Perl code that you execute from cPanel binaries. It is extremely important that you test your plugins and other custom code against Perl 5.22 to ensure that they continue to work correctly.

If you would like access to an early release of this change, subscribe to our EDGE users mailing list.