cPanel® Blog

Unblocking MySQL 5.5 on cPanel & WHM version 78

Good news for MySQL 5.5 users! We have been able to plan the removal of the blocker from cPanel & WHM version 78 which prevented you from upgrading to our LTS version 86. 

Soon, you’ll be able to upgrade to the supported version 86 even if you are still using MySQL 5.5. Keep in mind that cPanel and WHM version 86 contains rudimentary functionality only for existing installations of MySQL 5.5, and you should upgrade to MySQL 5.7 as soon as you are able. 

As MySQL 5.5 reached its end of life on December 3, 2018, per cPanel L.L.C.’s End of Life Policy, we no longer provide support for MySQL 5.5. cPanel typically does not support outdated and end-of-life software. We need to dedicate development resources to test and patch supported versions of third-party software such as MySQL. Any support or development resources used on unsupported and outdated versions detract from these efforts.

We are removing the blocker to strongly encourage you to upgrade both MySQL and cPanel & WHM to supported versions. After you upgrade both sets of software, you will be able to receive support from cPanel and offer your customers a supported and more stable and secure platform. 

Performing the upgrade:

Once this change is made, you can use WHM’s MySQL/MariaDB Upgrade interface (WHM >> Home >> SQL Server >> MySQL/MariaDB Upgrade) to upgrade the database on your server to a supported version.

Caveats:

cPanel and WHM Version 88:

  • Servers that use MySQL 5.5 on cPanel & WHM cannot upgrade to cPanel & WHM version 88 and newer.

Support:

  • If you require support, you must upgrade your server to use a newer supported database such as MySQL 5.7.  Find out how to get the best support experience by reading our blog post, “Anatomy of a support ticket“.

Third-Party Applications:

  • Many third-party applications no longer support MySQL 5.5. For example, WordPress® requires MySQL 5.6 or newer for new installations.

Security:

  • Running the latest versions of cPanel & WHM keeps your server updated with the latest stable software and security updates.

In a future version of cPanel & WHM, we plan to remove functionality for MySQL 5.5. If you attempt to upgrade a cPanel & WHM version server that does not contain MySQL 5.5 functionality, you will encounter errors. To prevent these errors, you must upgrade your server to use a newer supported database such as MySQL 5.7 or later.

As always, if you have any feedback or comments, please let us know. We are here to help in the best ways we can. You’ll find us on Discord, the cPanel forums, and Reddit.

cPanel

The web hosting industry's most reliable management solution since 1997. With our first-class support and rich feature set, it's easy to see why our customers and partners make cPanel & WHM their hosting platform of choice. For more information, visit cPanel.net.